prevent negative values for passive tracer concentration

I am running a simulation where I have a passive tracer with a non-zero concentration in a small portion of the domain and a zero concentration everywhere else. I would like to prevent negative values for the passive tracer concentration. I have tested different advection scheme (UP, WENO) and different mixing scheme (LMD, GLS) but they all yield pretty strong negative values. Is there a way to prevent those?
Thank you,

Did you try to define all TS_HADV_WENO5, TS_VADV_WENO5, UV_HADV_WENO5 and UV_VADV_WENO5?

Hi Patrick. Yes, they are all defined. Note that I have both UV_VADV_SPLINES
and UV_VADV_WENO5 in the active CPP options. I wonder if there is a conflict there.

yes there is conflict of course (SPLINES will be chosen).

Hi Bertrand. I also have the same problem. Have you tried the ‘BIO_HADV_WENO5’ CPP option? The CROCO user guide says that advection scheme is used for passive tracer.

Hi Patrick and Xupeng. I did resolve the confict so I am using only TS_HADV_WENO5, TS_VADV_WENO5, UV_HADV_WENO5, UV_VADV_WENO5 and BIO_HADV_WENO5 but negative values for the passive tracer concentration persists. Please let me know if you have any insights on how to avoid that. Thank you.


I posted this: a while ago about the issue I had with adding a passive tracer in my buoyant plume simulations. I later found that the source code that computes tracer surface flux needed to be modified. I made some changes in the code and the results looked reasonable afterwards. Maybe you are having the same issue?

Interesting, let me look into that. Thank you, Xupeng.

@patrick: maybe something you would like to check as well?

Hi Bertrand, I am curious to know if your issue has been resolved after changing the source code as described in my previous post?