Error with Easy interactive grid maker in make_grid

Dear CROCO users,

During the process of making the grid using make_grid function, I choose yes for the question within the process below:

Do you want to use interactive grid maker?

(e.g., for grid rotation or parameter adjustments) : y

My question is why the interactive grid maker GUI is always located in the Benguela Model location, even though I have changed the latitude-longitude to my area of interest in the crocotools_param. Could you please help me how to solve this issue? Thank you.

Best regards,

Hi, I just used make_grid and selected easy grid maker

Do you want to use interactive grid maker ?
(e.g., for grid rotation or parameter adjustments) : y,[n] y

Use Easy interactive grid maker:
Update grid and click “Apply” in “Easy” window
(-> new parameters will be saved in easy_grid_params.mat)

and I get my new domain, not the Benguela model location.

Check if you saved your crocotools_param.m file.

Hi Andres,

Thank you for your response. I have checked again my crocotools_param.m file and it shows the new coordinate domain other than the Benguela model location.

Actually, when I click “Apply” in “Easy” windows, I get the new domain afterwards (not the Benguela model location). However, during the process of using “Easy” windows, the location is always shown as the Benguela location, this makes it difficult for applying the features inside the “Easy” windows such as “rotation”, moving the centre of the domain, etc. I have tried using Matlab versions 2015b and 2018b and gave me similar results.

Kind regards,