Error: READ_INP ERROR while reading block with keyword 'auxiliary_history_fields'

Hello everyone,

I am trying to configure CROCO for a test case with the simple biogeochemical model BIO_NChlPZD. I already made all my files correctly and all seem to work well.

However, when I try to run the model after compilation. I had this error:

 READ_INP ERROR while reading block with keyword 'auxiliary_history_fields'.

 READ_INP ERROR: A total of  1 configuration errors discovered.

I’m not sure where the problem lies for this simple case. Has anyone encountered such problem before? I will be glad to be pointed to the right direction to solve this problem.
I copy my and cppdefs.h file here.



What version of CROCO are you using? Have you tried with the Benguela test case?

Hi Andres, I am using the V1.2. As a matter of fact, I’m following your tutorial when I encountered the error. Still haven’t solved it yet.

Ok, great. Which tutorial in particular?

Tutorial 5 (Biogeochemical simulation). I think that’s the basic tutorial.

Try this. Replace 10T with 30T in the line below auxiliary_history_fields and also for the line below

It works like charm. What difference does 10 and 30*T makes. Is the difference because I have additional tracers? Thanks Andres

Yes, it expects more logical values (T or F) for the extra tracers. I think this is fixes in the latest version. Glad that it works now. Any comments on the tutorial are very much welcomed!

Thanks once again.