1D Atmospheric model - KILPATRCK test case error

The KILPATRICK test case for testing the new 1 dimensional Atmospheric model appears to have an 1 dimensional grid on the X direction according to the param.h file:
#elif defined KILPATRICK
parameter (LLm0=600, MMm0=3, N=2) ! KILPATRICK

When I run the test case the model appears to run fine but it fails to record anything on the Y-direction (failed parameters to write in the netCDF are: vbar, v, eta_v).

The error I am getting is:
NF_FWRITE_Y ERROR: nf_put_vara netCDF error code = -57 mynode = 1

WRT_GRID - error while writing variable ‘eta_v’ into
netCDF file ‘croco_his.nc’.

I changed the settings in the croco.in.kilpatrick input file for vbar and v to FALSE for not recording them, but I am still getting the error for eta_v which is not specified in the croco.in file.

Any ideas how to fix the Y-direction parameters errors?


I just ran it without error in sequential with CROCO V2.0.0.

What is the version of CROCO you are using ?

Thank you Solène for the reply,

I was also using CROCO v2.0 but I realised the problem was with the MPI configuration. Specifically, I had NP_ETA=7 which was greater than the ETA dimension of the grid (MMm0=3) and that was creating the problem. I tried with the MPI configurtion below and worked fine :slight_smile:

#ifdef MPI
parameter (NP_XI=2, NP_ETA=2, NNODES=NP_XI*NP_ETA)