Ask Your Question

Revision history [back]

Running with MPI problem in latest code

Hi,

I just downloaded the master branch of the code to test the MPI_NOLAN switch.

Compilation went ok using mpif90, but when I try to run the code I get the following error.

The name of the GRD file is ok and located in the same directory as the executable and .in file

Any clues about this?

mpiexec -n 44 ./croco_mpi_44 croco_pisces_rios_v2.in Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed

Reading mask file failed

MPI_ABORT was invoked on rank 26 in communicator MPI_COMM_WORLD with errorcode 0.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes. You may or may not see output from other processes, depending on

exactly when Open MPI kills them.

Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed [debian:07420] 43 more processes have sent help message help-mpi-api.txt / mpi-abort [debian:07420] Set MCA parameter "orte_base_help_aggregate" to 0 to see all help / error messages