Ask Your Question
0

compile error for version 1.2

asked 2022-02-18 03:26:00 +0200

DJ gravatar image

Hi,

I wonder if anyone has encountered the following error while compiling CROCO ver 1.2.

gmake: Circular oce_sed.mod <- oce_sed.o dependency dropped.
m2c -o oce_sed.o oce_sed.mod
gmake: m2c: Command not found
gmake: * [oce_sed.o] Error 127

It looks like the object file, ocean.sed.o is sediment transport module which I did not activate.

I tried to compile with some test cases including upwelling, but none of them worked. I did not have the same error for version 1.1, which works fine. I tried openmpi + gfortran and intel fortran + intelmpi and neither worked.

I wanted to ask on this forum before I start looking at the makefile.

Thanks in advance.

-DJ

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2022-02-18 17:29:43 +0200

Hello,

Did you check that the source path in your jobcomp is correct ? It should point to your "OCEAN" directory and make sure you have all the others directories of CROCO source code next to OCEAN. SOURCE=/home/test/croco/OCEAN

Matthieu

edit flag offensive delete link more

Comments

Yes.

DJ gravatar imageDJ ( 2022-02-18 22:36:44 +0200 )edit
0

answered 2022-02-18 13:46:54 +0200

Rachid gravatar image

Hi Just to make sure, can you just in your Run directory remove the Compile directory and re-launch jobcomp ? Rachid

edit flag offensive delete link more

Comments

Thanks for your comment. That makes no difference. The same error. jobcomp and Makefile between v1.1 and v1.2 are similar and no red flags so far. I compared ver 1.1 and ver 1.2 compiling log and it looks like the error occurred when compiling CROCO was either pisces_ini or module_parameter_oa.F.

DJ gravatar imageDJ ( 2022-02-18 15:01:44 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2022-02-18 03:26:00 +0200

Seen: 72 times

Last updated: Feb 18