Ask Your Question
0

Is the floats module working with MPI?

asked 2021-03-15 16:02:17 +0200

updated 2021-03-15 16:04:48 +0200

I am trying to set up online particle tracking in CROCO but am having some difficulties. I firstly tried implementing floats in my working high-resolution hindcast configuration but was getting segmentation faults so I tried it with the BASIN test case instead.

When I run the BASIN test case in serial (without MPI), the floats module works well and I get sensible output. However, when I run the BASIN test case with MPI (regardless of the number of cores), the model crashes after the first time-step with the following error:

WRT_FLT ERROR while writing variable 'time_step' into float file. 
          Time record:    2  netCDF error code -33
          Cause of error: NetCDF: Not a valid ID                     mynode =   0

WRT_FLT ERROR: Cannot synchronize/close float netcdf file.

(To be clear, the BASIN test case works fine with MPI if floats is not used). I am using the latest croco-v1.1 and have experienced the same issue across multiple machines.

Does anybody else has a working MPI configuration with floats and if there are any special configuration options that are required?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2021-03-15 16:07:29 +0200

Rachid gravatar image

Hi

It doesn't work with MPI. Not just a bug, the whole implementation is not there. It should work with OPENMP Rachid

edit flag offensive delete link more

Comments

That makes sense - thanks!

Beaufort gravatar imageBeaufort ( 2021-03-15 16:15:38 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-03-15 16:02:17 +0200

Seen: 32 times

Last updated: Mar 15