Ask Your Question
0

sustr and svstr values missing!

asked 2021-01-20 19:54:38 +0200

Hi All, I am running a simulation using bulk forcing file containing the following variables: [bulk_time, tair, rhum, prate, radlw_in, radsw, uwnd, vwnd, wspd]. I am also using #define BULK_FLUX option in cppdefs.h file.

When I saw the values of variables sustr and svstr in output history file they are all blank. They look like this: ncdump -v sustr croco_his.0000.nc >
_, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _, _

Which means values are blank. Am I doing anything wrong?
Here is my cppdefs.h file.txt

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2021-01-21 16:53:38 +0200

updated 2021-01-21 16:54:19 +0200

(1) I want to add that my bulk forcing file has uwnd and vwnd, but it does not have surface wind stress u-stress and v-stress. I am guessing the bulk algorithm calculates u-stress and v-stress using uwnd and vwnd?

(2) Also, wspd is still required to be specified? wspd is not evaluated using uwnd and vwnd at each grid point? I am aware that wspd is required for bulk algorithm. So the bulk algorith eventually needs wspd.

So my question is: if I am using bulk cpp option, can I only specify uwnd and vwnd and rest will be taken care of?

edit flag offensive delete link more

Comments

Hi (1) You don't need u-stress and v-stress if you are giving wind speeds in the bulk file and use #define BULK_SMFLUX in your cppdefs file. (2) Yes, wspd has to be specified. It is used in latent and sensible flux as well. Besides, for average values wspd^2 is not equal to uwnd^2 + vwnd^2 anymore.

MartinV gravatar imageMartinV ( 2021-01-21 20:22:02 +0200 )edit

Hi Martin, I tried with define bulk_smflux set to true and gave only uwnd and vwnd (and wspd).I don't have sustr and svtsr in blk.nc. Now I am seeing zero values (but not blank) for sustr and svstr in the output his netcdf file for later values too. Any guess as to why I am seeing zero sustr values?

aakashsane gravatar imageaakashsane ( 2021-01-21 22:00:49 +0200 )edit

Atleast I am not getting blank values. But I think something is making the surface stress take zero values only. I have checked for uwnd and vwnd, and they are fine. I am not sure what is going wrong.

aakashsane gravatar imageaakashsane ( 2021-01-21 22:04:15 +0200 )edit

Sadly I have no idea what is setting your stress to 0. I would suggest to copy the bulk_flux.F to the Run folder and output some of the variables during runtime, to see where the zeros appear.

MartinV gravatar imageMartinV ( 2021-01-23 11:21:56 +0200 )edit

Hi Martin, I did a clean compilation using bulk_smflux and I also made the other variables: humidity, air temperature, etc on the [bulktime, etarho, xirho] grid. Now I am getting some physically okay u,v stress values. So the problem is solved I guess. Thanks for helping out!

aakashsane gravatar imageaakashsane ( 2021-01-23 14:54:26 +0200 )edit
0

answered 2021-01-21 13:56:34 +0200

andres gravatar image

Hi, check that your input, croco_blk.nc file has non-zero values. I did a quick check doing make_bulk for the Benguela test case and all is fine, all are valid values and the first one is not zero.

Maybe is not well defined in the code as an output variable.

edit flag offensive delete link more

Comments

Hi Andres, which variables in blk.nc should be non zero? Because uwnd and vwnd will have +ve and -ve values right?

aakashsane gravatar imageaakashsane ( 2021-01-21 14:05:47 +0200 )edit
0

answered 2021-01-21 09:43:53 +0200

Hi! The first output in his file is the initial state and wind stress is set to 0. You should get non-zero values in the next output. Best, Martin

edit flag offensive delete link more

Comments

HI Martin, I am running my own simulation where I am giving bulk forcing. I am trying out various ways in which CROCO takes wind and atmospheric forcings (bulk file, AROME style bulk forcing file, etc.). I am not getting non zero values but all are blank.

aakashsane gravatar imageaakashsane ( 2021-01-21 14:22:37 +0200 )edit

Sorry, my mistake. I never had this issue. Is maybe wspd set no NaN in the bulk file?

MartinV gravatar imageMartinV ( 2021-01-21 20:24:10 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-01-20 19:54:38 +0200

Seen: 156 times

Last updated: Jan 21