Ask Your Question
0

Running with MPI problem in latest code

asked 2020-08-21 22:27:39 +0200

andres gravatar image

Hi,

I just downloaded the master branch of the code to test the MPI_NOLAN switch.

Compilation went ok using mpif90, but when I try to run the code I get the following error.

The name of the GRD file is ok and located in the same directory as the executable and .in file

Any clues about this?

mpiexec -n 44 ./croco_mpi_44 croco_pisces_rios_v2.in Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed

Reading mask file failed

MPI_ABORT was invoked on rank 26 in communicator MPI_COMM_WORLD with errorcode 0.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes. You may or may not see output from other processes, depending on

exactly when Open MPI kills them.

Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed Reading mask file failed [debian:07420] 43 more processes have sent help message help-mpi-api.txt / mpi-abort [debian:07420] Set MCA parameter "orte_base_help_aggregate" to 0 to see all help / error messages

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2020-08-24 23:01:31 +0200

andres gravatar image

Yes, thanks that problem disappeared. The server is bussy now, I will check later if it stops somewhere else. Thanks Rachid.

edit flag offensive delete link more
0

answered 2020-08-23 17:18:36 +0200

Rachid gravatar image

Hi

As it is, with the NO_LAND option, the name of the grid file is harcoded in MPI_setup.F (not obvious to do otherwise). So your grid file has to be called croco_grd.nc. Is it your case ? Rachid

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-08-21 22:27:39 +0200

Seen: 793 times

Last updated: Aug 24