Ask Your Question
0

Setting up CROCO - Fatal error during jobcomp

asked 2019-11-22 08:03:14 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >5 is welcome to improve it.

Hi everyone,

I am new to CROCO, and am trying to set it up onto my personal pc.

I have managed to download all the necessary compilers and libraries; however, when I try to run the ./jobcomp command, I get the following error:

cpp -traditional -DLinux -P -Inf-config not yet implemented for cmake builds -ICROCOFILES/AGRIF_INC mpc.F > mpc_.f cpp: fatal error: too many input files

compilation terminated.

Makefile:188: recipe for target 'mpc' failed

make: * [mpc] Error 1

cpp -traditional -DLinux -P -Inf-config not yet implemented for cmake builds -ICROCOFILES/AGRIF_INC par_pisces.F90 > par_pisces_.f90

cpp: fatal error: too many input files

compilation terminated.

Makedefs:21: recipe for target 'par_pisces.o' failed make: * [par_pisces.o] Error 1

Does anyone know what the problem could be? Any help is greatly appreciated.

Thank you in advance!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-11-22 10:04:19 +0100

Okay, so I figured out the issues.

I found that I needed to install the correct netcdf libraries, as well as set the environments in the .bashrc script.

I added the following lines at the bottom of the script:

export NETCDF_LIBDIR=/usr/include

export NETCDF_INCDIR=/usr/include

export NF_CONFIG=/usr/bin/nf-config

finally, then in the jobcomp file, I changed the following line:

NETCDFLIB="-L/usr/local/lib -lnetcdf"

to

NETCDFLIB="-L/usr/local/lib -lnetcdff"

(The only difference between the two lines is that there's an extra 'f' at the end of lnetcdf)

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-11-22 08:03:14 +0100

Seen: 60 times

Last updated: Nov 22