Ask Your Question
0

daily river discharges?

asked 2019-07-29 02:39:50 +0200

camila gravatar image

Hi, I have a simulation forced with daily winds close to uruguayan maritime zone wich runs ok. Currently I am trying to add daily river discharges , so I created one forcing runoff file containing 15 years of daily discharges (I created it simply by changing variable and dimensions in the croco_runoff.nc file created in matlab containing climatological discharges).

The problem is when I try to run the model, it gives me a set_cycle error, SET_CYCLE ERROR: non-cycling regime, but model time exeeds time of the last available data record for variable: qbar_time TDAYS = 0.7414E+05 TLAST = 0.7962E+05

Where Tlast is the last day of my 15 years period, I think it is cause my forcing files are all monthly files and my runoff is only one file containing daily values for the whole 15 year period.

SO anyone could help me, what should I do? Should I split my runoff file in monthly runoff files? If so, where should I indicate the model to take monthly runoff files?

Many thanks to any help! CAmila

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2019-07-30 17:55:52 +0200

camila gravatar image

Hi Gildas, many thanks for your answer! You were right I had two days missing min my qbar_time. I also added the bug fixes and it is running now.

However I still have some doubts about where is the model taking salt and temp from.

I have defined

define PSOURCE_NCFILE

ifdef PSOURCE_NCFILE

define PSOURCE_NCFILE_TS

endif

and I have T and S varible in my runoff.nc file, but I also have some values in my .in, which I am not sure if should I leave there or not.

psource_ncfile: Nsrc Isrc Jsrc Dsrc qbardir Lsrc Tsrc runoff file name /home/camila/croco_runoff.nc 1
45 122 1 -1 T T 25. 2.

So is the model considering 25. and 2. from the .in file or is it just taking those from the runoff forcing file?

Also, I did not add qbar direction nor position in my runoff file and only added in the .in file, is it correct to do that? (I did it because for my 2nd child grid I have divided my river flux in 6 sources).

Many thanks again! Camila

edit flag offensive delete link more
0

answered 2019-07-29 18:22:28 +0200

GildasC gravatar image

The bug fixes are here , https://www.croco-ocean.org/download/...

at the section Know problemes and fixes, with a patch especially for Rivers.

edit flag offensive delete link more
0

answered 2019-07-29 18:20:19 +0200

GildasC gravatar image

Hi Camilla,

First have a look on the very recent bug fixes there :

You have this message because the model time exed the qbar_time of your croco_runoff.nc files. Your qbar time is probably not coorect or long enought,

Saludos, Gildas

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-07-29 02:39:50 +0200

Seen: 550 times

Last updated: Jul 30