Ask Your Question
0

COMPILELING WRF for COUPLING

asked 2023-11-21 07:41:09 +0100

yxli gravatar image

I tried to configure the coupling model using Ubuntu22.04. Four files appear when compiling the original wrf, but the following error occurs when compiling the WRF with the OASIS entry. How can I solve it? My compiler version is gcc-11.4.0.

Here are my compile.log and configure.wrf files. C:\fakepath\compile.exe_coupled.log C:\fakepath\configure.txt

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2023-11-22 09:44:54 +0100

swen gravatar image

updated 2023-11-22 09:45:46 +0100

Your problem is that you have not set up correctly the compilers for mpi compilation (which is mandatory with OASIS). In your configure.wrf you currently have :

SFC             =       gfortran
SCC             =       gcc
CCOMP           =       gcc
DM_FC           =       mpif90 
DM_CC           =       mpicc 
FC              =       time $(SFC)
CC              =       $(SCC) -DFSEEKO64_OK 
LD              =       $(FC)

while you should have something like :

SFC             =       gfortran
SCC             =       gcc
CCOMP           =       gcc
DM_FC           =       mpif90
DM_CC           =       mpicc
FC              =       $(DM_FC)
CC              =       $(DM_CC) -DFSEEKO64_OK
LD              =       $(FC)

You can check a configure.wrf example in the directory WRF_IN/CONFIGURE_WRF/Linux

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2023-11-21 07:41:09 +0100

Seen: 368 times

Last updated: Nov 22